Changer la version de PHP de son hébergement web

Découvrez comment changer la version de PHP de votre hébergement web OVHcloud

Dernière mise à jour le 19/09/2022

Objectif

Votre hébergement web OVHcloud permet d’héberger le site internet que vous souhaitez, tant que celui-ci est compatible avec la configuration de nos infrastructures. En ce sens, vous pouvez être amené à vouloir modifier la version de PHP utilisée par votre hébergement web.

Découvrez comment changer la version de PHP de votre hébergement web OVHcloud.

Prérequis

En pratique

Plusieurs versions du langage de programmation PHP existent. Les évolutions de versions apportent des correctifs divers, ainsi que l'ajout ou l'arrêt de fonctionnalités. OVHcloud propose les dernières versions majeures de PHP dont vous pouvez retrouver la liste ici.

Du fait que certaines fonctionnalités peuvent ne pas être maintenues au fil des nouvelles versions, assurez-vous, avant d'entamer tout changement, que la nouvelle version de PHP souhaitée est compatible avec votre site internet.

Étape 1 : s'assurer que votre site est compatible

Même si OVHcloud gère l'installation des dernières versions de PHP sur ses serveurs, il vous revient en tant que webmaster de vous assurer que votre site internet est toujours à jour et donc compatible avec les dernières versions de PHP. Afin de vous en assurer, deux possibilités existent selon le site internet que vous utilisez :

Cas n°1 : vous utilisez un site « clés en main » comme un système de gestion de contenu (Content Management System ou CMS) tel que WordPress, Joomla!, PrestaShop ou Drupal :

  • Consultez la documentation officielle créée par l'éditeur du CMS que vous utilisez.
  • Prenez note des informations concernant les prérequis techniques indispensables au fonctionnement de votre CMS, ainsi que la manipulation permettant de le mettre à jour.
  • Si nécessaire, mettez à jour votre CMS en vous assurant que la nouvelle version est compatible avec l'hébergement OVHcloud.

Cas n°2 : vous utilisez un site basé sur une solution personnalisée :

  • Rapprochez-vous du webmaster ayant créé le site internet.
  • Aidez-vous de la documentation officielle PHP donnant plus d'informations sur les migrations de version.
  • Si nécessaire, mettez à jour le code de votre site en vous assurant que celui-ci reste compatible avec l'hébergement OVHcloud.

Si besoin, vous pouvez connaître la version de PHP actuellement utilisée par votre hébergement de deux façons :

  • via l'espace client OVHcloud : connectez-vous à l'espace client, rendez-vous dans la partie Web Cloud, cliquez sur Hébergements puis choisissez l'hébergement web concerné. Dans l'onglet Informations générales, repérez la version en dessous de Version PHP globale.

phpversion

Si un symbole rond de couleur bleue est présent, patientez quelques minutes le temps que la version s'actualise.

  • via un script : Créez un script .php contenant uniquement le code <?php phpinfo(); ?>. Mettez-le ensuite en ligne sur votre espace de stockage FTP, puis appelez-le en accédant à son adresse/URL complète.

Si vous n'arrivez pas à vous assurer de la compatibilité de votre site internet avec la nouvelle version de PHP et même si nous déconseillons vivement cette méthode, vous pouvez essayer de changer la version actuelle et de revenir en arrière. Cependant, vous prenez alors le risque de générer un potentiel dysfonctionnement sur votre site internet. D'ailleurs, même si celui-ci s'affiche toujours après le changement, il se peut que l'une de ses fonctionnalités spécifiques en soit affectée et devienne inopérante.

Dès que vous êtes prêt à réaliser le changement, poursuivez vers l'étape 2.

Étape 2 : modifier la version de PHP de votre hébergement web

Il existe deux manières de modifier la version de PHP de votre hébergement web :

La modification de la version de PHP via un fichier « .htaccess » n'est plus possible sur les dernières offres d'hébergement web OVHcloud.
La commande permettant de changer la version de PHP dans le fichier « .htaccess » ne permet pas d'utiliser les versions récentes de PHP sur nos infrastructures.
Pour cela, vous devrez obligatoirement utiliser le fichier .ovhconfig en vous aidant de notre documentation « Configurer le fichier .ovhconfig de mon hébergement web ».

Certaines versions de PHP ne fonctionnent qu'avec certains environnements d'exécution. Vous trouverez ci-après les versions de PHP disponibles sur les hébergements mutualisés OVHcloud et les environnements d'exécution compatibles :

Versions PHP Environnements d'exécution compatibles
5.4, 5.5, 5.6 et 7.0 Legacy, Stable
7.1, 7.2 et 7.3 Stable
7.4, 8.0 et 8.1 (bêta) stable64

Aller plus loin

Modifier la configuration de son hébergement web

Configurer le fichier .ovhconfig de son hébergement web

Se connecter à l’espace de stockage de son hébergement Web

Pour des prestations spécialisées (référencement, développement, etc), contactez les partenaires OVHcloud.

Si vous souhaitez bénéficier d'une assistance à l'usage et à la configuration de vos solutions OVHcloud, nous vous proposons de consulter nos différentes offres de support.

Échangez avec notre communauté d'utilisateurs sur https://community.ovh.com


Did you find this guide useful?

Please feel free to give any suggestions in order to improve this documentation.

Whether your feedback is about images, content, or structure, please share it, so that we can improve it together.

Your support requests will not be processed via this form. To do this, please use the "Create a ticket" .

Thank you. Your feedback has been received.


These guides might also interest you...

OVHcloud Community

Accedez à votre espace communautaire. Posez des questions, recherchez des informations, publiez du contenu et interagissez avec d’autres membres d'OVHcloud Community.

Echanger sur OVHcloud Community