Cambiar la versión de PHP de un alojamiento web

Cómo cambiar la versión de PHP de un alojamiento web de OVHcloud

Última actualización: 19/09/2022

Esta traducción ha sido generada de forma automática por nuestro partner SYSTRAN. En algunos casos puede contener términos imprecisos, como en las etiquetas de los botones o los detalles técnicos. En caso de duda, le recomendamos que consulte la versión inglesa o francesa de la guía. Si quiere ayudarnos a mejorar esta traducción, por favor, utilice el botón «Contribuir» de esta página.

Objetivo

Su plan de hosting de OVHcloud permite alojar el sitio web que desee, siempre que sea compatible con la configuración de nuestras infraestructuras. En este sentido, quizá desee modificar la versión de PHP utilizada por su alojamiento web.

Descubra cómo cambiar la versión de PHP de un alojamiento web de OVHcloud.

Requisitos

Procedimiento

Existen varias versiones del lenguaje de programación PHP. La evolución de las versiones aporta varios parches, así como la adición o interrupción de las funcionalidades. OVHcloud ofrece las últimas versiones mayores de PHP, que puede consultar en la lista aquí.

Debido a que algunas funcionalidades pueden no mantenerse en las nuevas versiones, asegúrese, antes de realizar cualquier cambio, de que la nueva versión de PHP deseada es compatible con su sitio web.

Etapa 1: asegurarse de que su sitio web es compatible

Aunque OVHcloud gestiona la instalación de las últimas versiones de PHP en sus servidores, usted es el webmaster quien debe asegurarse de que su sitio web está siempre actualizado y, por tanto, es compatible con las últimas versiones de PHP. Existen dos formas de hacerlo, en función del sitio web:

Caso n°1: Si utiliza un sitio web "llave en mano" como un sistema de gestión de contenidos (content management system o CMS), como WordPress, Joomla, PrestaShop o Drupal:

Consulte la documentación oficial creada por el editor del CMS que utilice. - Tome nota de la información relativa a los requisitos técnicos necesarios para el funcionamiento de su CMS, así como de la operación necesaria para actualizarlo. Actualice su CMS para asegurarse de que la nueva versión es compatible con el alojamiento de OVHcloud.

Caso n°2: si utiliza un sitio web basado en una solución personalizada:

Acceda al webmaster que haya creado el sitio web. - Si desea más información sobre las migraciones de versión, consulte la documentación oficial de PHP. Actualice el código del sitio web, garantizando que siga siendo compatible con el alojamiento de OVHcloud, si es necesario.

Si lo necesita, puede consultar la versión actual de PHP del alojamiento de dos formas distintas:

  • Desde el área de cliente de OVHcloud : conéctese al área de cliente, acceda a la sección Web Cloud, haga clic en Alojamientos y seleccione el alojamiento correspondiente. En la pestaña Información general, localice la versión a continuación de Versión PHP global.

phpversion

Si aparece un círculo de color azul, espere unos minutos a que se actualice la versión.

  • a través de un script : Cree un script .php que contenga únicamente el código <?php phpinfo(); ?>. Haga clic en su espacio de almacenamiento FTP y llámelo accediendo a su dirección URL completa.

Si no puede comprobar que su sitio web es compatible con la nueva versión de PHP y aunque desaconseja este método, puede intentar cambiar la versión actual y volver atrás. pero corre el riesgo de generar un posible fallo de funcionamiento en su sitio web. Por otra parte, incluso si este se sigue mostrando después del cambio, es posible que alguna de sus funcionalidades específicas se vea afectada y se torne inoperante.

Una vez que esté listo para realizar el cambio, vaya al paso 2.

Etapa 2: cambiar la versión de PHP de un alojamiento web

Existen dos formas de modificar la versión de PHP de un alojamiento web:

La modificación de la versión de PHP a través de un archivo ".htaccess" ya no es posible en los últimos planes de hosting de OVHcloud.
El comando que permite cambiar la versión de PHP en el archivo ".htaccess" no permite utilizar las versiones recientes de PHP en nuestras infraestructuras.
Para ello, deberá utilizar obligatoriamente el archivo .ovhconfig con ayuda de nuestra documentación "Configurar el archivo .ovhconfig de mi alojamiento web".

Algunas versiones de PHP sólo funcionan con algunos entornos de ejecución. A continuación encontrará las versiones de PHP disponibles en los alojamientos compartidos de OVHcloud y los entornos de ejecución compatibles:

Versiones PHP Entornos de ejecución compatibles
5.4, 5.5, 5.6 y 7.0 Legacy, Stable
7.1, 7.2 y 7.3 Stable
7.4, 8.0 y 8.1 (bêta) stable64

Más información

Modificar la configuración de un alojamiento web

Configurar el archivo .ovhconfig de un alojamiento web

Conectarse al espacio de almacenamiento de su alojamiento web

Para servicios especializados (posicionamiento, desarrollo, etc.), contacte con partners de OVHcloud.

Si quiere disfrutar de ayuda para utilizar y configurar sus soluciones de OVHcloud, puede consultar nuestras distintas soluciones pestañas de soporte.

Interactúe con nuestra comunidad de usuarios en https://community.ovh.com/en/.


Did you find this guide useful?

Please feel free to give any suggestions in order to improve this documentation.

Whether your feedback is about images, content, or structure, please share it, so that we can improve it together.

Your support requests will not be processed via this form. To do this, please use the "Create a ticket" .

Thank you. Your feedback has been received.


These guides might also interest you...

OVHcloud Community

¡Acceda al espacio de la OVHcloud Community! Resuelva sus dudas, busque información, publique contenido e interactúe con otros miembros de la comunidad.

Discuss with the OVHcloud community